Need help for your robot?

Here are video tutorials and answers to the most common questions

Video tutorials

Explanatory videos to know: - How to connect / disconnect the cables of your robot - How to disassemble the engine - How to reassemble the engine - How to change the filter / filter basket - Why LEDs blink they - How to assemble and disassemble drive belts from 7310

7310
5220-J10-LUNA 10
5210-J200
5200-J2X

Frequently asked Questions

5200-J2X/5210-J200/5220-J10-LUNA10

List of answers to common questions

- Electrical outlet / inter differential:

Check that the electrical outlet you are using is working by plugging another appliance into the outlet

Check if the differential inter did not trip.

- The plug is not connected correctly to the plug:

Disconnect the dry 30 power supply and then reconnect the power supply.

- No or not enough power transmitted to the robot:

Check all connection connections from the robot to the power source.

- An object blocks the rollers or one of the wheels of the robot:

Unplug the power supply and take the robot out of the water.

Open the robot to inspect it.

Check that there are no foreign objects in the turbines.

Make sure there are no foreign objects blocking the green rollers under the unit.

An object blocks the robot's rollers or one of the wheels: Unplug the power supply and take the robot out of the water. Open the robot to inspect the interior. Check that there are no foreign objects in the turbine or blocking the rollers.

- The bag is clogged or full: Clean the filter bag

- An object is stuck in the impeller or one of the valves: Check if the filter bag frame is correctly inserted.

- The robot moves too fast: Set the speed control knob to the lower level to reduce the speed of movement of the unit.

- Use a disposable fine filtration kit if you have very fine impurities (contact your dealer)

Current does not flow properly: Check all robot cable connections to the power source

- The pump motor is too old, the engine parts are worn out: Contact 8streme via www.8streme.com for spare parts. (If you live in Europe, go to 8streme.eu)

- Malfunction of the control circuit: Stop the robot immediately and contact the shop where you bought your robot.

7310 robot

List of answers to common questions

No or not enough power transmitted to the robot or object blocks the rollers, the paths or the wheels of the robot:

- Disconnect the power supply and take the robot out of the water.

- Open the basket lid and remove the basket.

- Check that there is no foreign object in the turbine located above the engine.

- Check that there are no foreign objects blocking the hydraulic system or the brushes and belts under the robot and on the sides.

The robot is not connected to a power source or the power is off:

- Check that the power source is active by plugging another device into the power outlet.

- Check that the power supply box is turned on.

- Check all connections of the robot to the source of love.

- The basket is clogged / full: Clean the basket and its filter panels. Clean the fine filter if you use this accessory. Check if the basket is correctly inserted.

-An object is stuck in the turbine or the grid located above the turbine: Check that there is no foreign object in the turbine or blocked in the grid above the turbine.

Not enough or too much floating wire in the pool: Make sure the length of cable floating in the pool is just the length needed. Remove the excess length of cable from the pool and leave this length outside the pool next to the power box.
Introduce the robot to the center point of the pool. If your pool is oval or rectangular, this point is half the length.

Can not find what you need?